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Documentation Updates

The documentation updates for Memento 12.0.0 are detailed in the table below.

Update description See section

New option: In the Go Back feature, you can use a filter as a
condition to pause the trace extraction.

"Monitoring Earlier
Stored Activity" on
page 21

Changed behavior: The traces are no longer cleared after a Go
Back action.

"Monitoring Earlier
Stored Activity" on
page 21

Memento User Guide Documentation Updates
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1. Memento Presentation

Memento is an advanced system for logging event messages. It greatly facilitates the debugging
of machine vision applications using Euresys frame grabbers. It is non-intrusive as the required
CPU load is extremely low.

The Memento system is made up of three main components: the Memento driver, the Memento
application and the Memento contributor(s).

Memento User Guide 1. Memento Presentation
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Memento Function Blocks and Data Flow

The Memento system works as described below and shown on the above schema:

1. The Memento Ring Buffer is a common memory space that the Memento driver reserves on
the computer and makes it known to the frame grabber drivers and libraries, as well as the
user space applications.

2. The Memento Contributors, that means the frame grabber drivers and libraries, the user
space applications and the Memento application itself, inject event messages - the Memento
Traces - into the ring buffer.

They time-stamp the Memento traces using a common time scale – the Memento Time Scale.

3. The Ring Filter, applied upstream of the ring buffer, allows you to filter the traces written in
the ring buffer.

4. The Memento application you can access in Console Mode or GUI Mode allows you to view
recent and past traces.

5. The Verbosity Filter, applied upstream of the Memento application, makes it possible to filter
the traces loaded into the Memento Viewer Buffer.

6. The Memento Viewer Buffer stores the traces that are made available in the Memento
application.

7. The Highlighting Filters, applied in the Memento application, make it possible to highlight or
hide the traces in the Memento application.

8. You can also dump the traces from the ring buffer using the Memento Dump Mode. This
dump mode is available from the Console or GUI interfaces.

Memento User Guide 1. Memento Presentation
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2. Starting Memento

NOTE You will find detailed information on how to set up Memento and
perform the initial configuration in the Getting Started guide (D602).

Start adding data to the ring buffer

When the PC hosting the Memento driver is running, the traces start being added to the ring
buffer as soon as one of the contributors sends Memento traces to the ring buffer.

As long as past activity is still available in the ring buffer, you will be able to view past traces in
the Memento application (GUI or Console mode) even if it was closed when the traces were
added.

Start the Memento application

To start the Memento application (graphical user interface), do one of the following actions:

● Click the Memento icon on the desktop.

● Select the application from the Windows Start Menu > Euresys Memento > Memento.

● Use the following command line from the Memento console: memento gui --hide-

console.

Options from the Windows Start menu

From the Windows Start Menu > Euresys Memento, you have a quick access to some options to
quickly perform a ring buffer configuration or save traces to a dump file:

Command Description

Record
Memento and
XPerf traces

This generates a .zip file including the memento dump with all the data
currently stored in the ring buffer, as well as the data collected by the
Windows Performance Monitoring tools.

This option is only relevant on Windows.

Reset Memento
to Default
Verbosity Level

This resets the ring buffer configuration to the Default profile.

See Setting up the Driver in the Getting Started guide (D602).

Memento User Guide 2. Starting Memento
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Command Description

Set Memento
to Highest
Verbosity Level

This sets the ring buffer configuration to the Verbose profile.

See Setting up the Driver in the Getting Started guide (D602).

Start Memento
Logging

This creates a dump file where all new data added to the ring buffer are
stored.

See the section Saving Traces (GUI) in the User Guide (D603) and (Console)
in the Reference Manual (D604) if you want to define additional parameters
for your dump file.

Memento User Guide 2. Starting Memento



10

3. Touring the Interface

This section provides an overview on the user interface mode of the Memento application.

The Memento application helps you among others to:

● filter traces to display and highlight the most relevant events in your processes.

● search for traces based on their content or their time stamp.

● rapidly spot errors or critical traces on a plot showing the recent activity and on a plot
displaying the number of events according to their criticality.

● investigate an issue by analyzing process-related events and state changes displayed as
waveforms.

● save traces from the current process to a dump file for further investigation.

3.1. Overview of Memento User Interface
Layout of the Memento user interface

Memento application – GUI mode – Main window

Memento User Guide 3. Touring the Interface



11

1. Control Bar: a set of buttons, check-boxes, text and slider controls.

2. Activity Plot: an area showing a graphical representation of the recent activity.

3. Message Plot: an area showing a graphical representation of a set of message traces.

4. Analyzer Plot: an area showing a graphical representation of process-related waveforms.
This area is only displayed when the Analyzer is enabled and open.

5. Tooltip Area: a text area showing the message corresponding to the position of the mouse
pointer, possibly completed with tooltip data.

6. Message List: a table showing a time-ordered list of messages with their attributes.

7. Status Bar: statistical and status information.

3.2. Control Bar

Starting from the left side, the Control bar contains the following controls:

Message search controls

Use this control to search for messages according to the search criteria entered in the Search
field. The search is applied to the information available in the Trace column.

Select the Aa check-box for case-sensitive searches.

Select the RE check-box for searches based on Perl-like regular expressions.

See the section "Searching for and Finding back Traces" on page 30.

Verbosity slider

Use this slider to change the verbosity level of the messages to display in Memento. The filter
applies to the messages displayed after defining the filtering criteria.

Moving the slider to the right increases the verbosity: more messages are displayed (less critical
messages are included).

Moving the slider to the left decreases the verbosity: less messages are displayed (focus on more
critical messages).

See the section "Filtering Traces for the Viewer Buffer" on page 49 for detailed information.

Memento User Guide 3. Touring the Interface
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Ring filters button

Use this control to view or refine the configuration settings for adding messages into the ring
buffer.

The messages that do not meet the filtering criteria will not be added to the ring buffer. In other
words, such messages will never appear in the Memento application.

See the section "Filtering Traces in the Ring Buffer" on page 46 for detailed information.

Highlighting filters button

Use this control to modify how traces are displayed in the Memento application (highlighting
traces, changing the message font color, hiding traces).

By default, filters 1 to 10 are disabled and filters 11 to 16 are enabled and implement the default
highlighting scheme.

See the section "Customizing Trace Display" on page 50 for detailed information.

Follow | Following button

|

Use this toggle button to control whether the message list is automatically scrolled down.

This function makes it possible to constantly display the most recent messages in the list or not.

See the section "Monitoring the Activity in Real Time" on page 20 for detailed information.

Run | Pause button

|

Use this toggle button to control whether the most recent messages are extracted from the ring
buffer to fill in the viewer buffer, and consequently whether the Memento application is fed with
these new messages from the viewer buffer.

See the section "Monitoring the Activity in Real Time" on page 20 for detailed information.

Memento User Guide 3. Touring the Interface
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Clear button

Use this button to clear all messages in the Memento application. This corresponds to clearing
the viewer buffer.

Go back button

Use this button to go back in time and display older messages in the Memento application.
Going back automatically clears the viewer buffer before reloading it with old messages still
available in the ring buffer.

See the section "Monitoring the Activity in Real Time" on page 20 for detailed information.

Menu button

Click this button to access the following functions:

● Clear search history to clear the history of the search strings in the Search field.

● Clear all user preferences to clear the history of all user preferences (verbosity filter, layout
preferences, etc.). The ring filter and highlighting filters are not reset with this control.

● Clear Analyzer preferences to clear the Analyzer configuration.

● Clear history before bookmark to clear the message list before the selected bookmark.

See also "Administration Tools" on page 68 for more information on the four functions
above-mentioned.

● Dump Memento data to file... to dump the content of the ring buffer to a file.

● Dump Memento section between bookmarks to dump the content of the ring buffer between
the time stamps of the selected bookmarks.

● Dump Memento selection to file to dump the content of the ring buffer between the time
stamps of the first and last selected messages.

See "Saving Traces" on page 60 for more information on the three functions above-
mentioned.

● Inject current time trace to inject a UTC time trace into the ring buffer.

See "Using Time Information" on page 66.

Memento User Guide 3. Touring the Interface
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● Reload Trace Definition to reload the trace dictionary used for mapping the trace references
stored in the ring buffer with the actual trace description displayed in the Memento
application.

See "Administration Tools" on page 68.

● Enable analyzer to extract the Analyzer traces to the viewer buffer and give access to the
Analyzer controls in the Memento application.

● Open analyzer to open the Analyzer Configurator and Analyzer Plot area. Only displayed
when the Enable Analyzer option is selected.

● Show analyzer traces to add Analyzer traces in the message list that correspond to the
events displayed in the Analyzer plot area.

See "Activating the Analyzer" on page 35 and "Configuring Traces for Analysis" on page 38 for
more information on the Analyzer module.

● About to view the version number of Memento.

3.3. Activity Plot
The Activity Plot area of the Memento application shows the recent message logging activity as
a graph:

Horizontal axis

The horizontal axis of the activity plot represents the time. The axis has a fixed scale and
subdivided with major divisions of 1 minute and minor divisions of 2.5 seconds.

The major divisions are labeled with the Memento time value. The time value represents the
time elapsed since you have started the Memento application.

The activity plot shows the activity in the last seven minutes. The rightmost end of the time
scale is the current time.

Vertical axis

The vertical axis of the activity plot represents the number of messages per second that are
effectively logged into the Memento ring buffer.

The axis is a logarithmic scale covering five decades:

● The first horizontal grid line is at 10 events per second

● The second horizontal grid line is at 100 events per second

● …

Memento User Guide 3. Touring the Interface
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Plot display

The plot display is composed of trace dots or lines. The dot or line color reflects the severity
level of the logged messages:

● The green color represents logged messages that are less critical than Notice.

● The yellow color represents Notice messages.

● The orange color represents Warning messages.

● The red color represents logged messages that are more critical than Warning.

You can click the activity plot to plot messages close to that point in time in the message plot.
This allows you to investigate errors appearing in red in the activity plot area.

Activity monitoring mode

The activity plot has two operation modes available by right-clicking the activity plot area:

● Accurate Activity Monitoring Mode (Default mode)

This mode takes into account the verbosity level of messages to generate the activity plot.
Consequently the notice, warning and more critical messages are represented respectively by
yellow, orange or red dots in the plot.

● Fast Activity Monitoring mode

This mode does not analyze the verbosity level of messages to generate the activity plot.
Consequently the plot is only represented as a green line, no matter how critical they are.
This mode can be useful if you need to alleviate the CPU workload.

3.4. Message Plot
The Message Plot area of the Memento GUI gives a time plot representing a set of message
traces.

Horizontal Axis

The horizontal axis of the message plot represents the time. The axis has a variable scale with
adaptive major and minor divisions.

Vertical Axis

The vertical axis of the message plot represents the verbosity level: the messages are
represented according to their verbosity level on the various horizontal lines displayed in the
message plot.

Memento User Guide 3. Touring the Interface
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● Messages with the highest verbosity level (Verbose) - the least critical - are represented on
the first level from the bottom.

● Messages with the lowest verbosity level (Critical) - the most critical - are represented on the
seventh level from the bottom.

Message Symbols

A message is represented by the symbol =. The symbol color matches the background color
settings defined in the Highlighting Filters.

The portion of the message plot represented below shows:

● First several Debug messages (2nd level from bottom) and Info messages (3rd level from
bottom) have been issued at the same time as an Error message in red (6th level from
bottom).

● Straight after these messages, a Debug and Info messages were issued at the same time as a
Warning message in orange (5th level from the bottom).

3.5. Analyzer Plot
The Analyzer Plot area of the Memento application displays waveforms corresponding to
specific types of events you want to analyze.

Once you have selected these types of events in the Analyzer configuration, the corresponding
waveforms are displayed in the Analyzer plot.

Horizontal axis

The horizontal axis of the Analyzer plot represents the time. The axis has a variable scale with
adaptive major and minor divisions.

Vertical Axis

The vertical axis of the Analyzer plot shows the waveforms selected in the Analyzer
configuration.

For the waveforms selected in the Analyzer configuration, the following information is
displayed:

Memento User Guide 3. Touring the Interface
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● the name of the waveforms on the left, and the reference to the related frame grabber card,
connector and possibly stream.

● the waveform displaying the occurred events (Analyzer traces). These events can belong to
one of the following types:

□ Process start (level up)

□ Process reset (level down)

□ Counter (calculated value)

3.6. Message List
The Message List area of the Memento GUI displays a time-ordered list of messages.

The message list is represented as a table with one row per message, and several columns
including the message-related data fields.

Data Fields

The following data fields can be displayed in the message list:

● Seq: the sequential number assigned by Memento when a message is entering the Memento
ring buffer

● Time: the time attribute value assigned by the message contributor and expressed in seconds
with 6 decimals

● Delta: the time offset relative to the user-defined time reference; the value is expressed in
seconds with 6 decimals

Memento User Guide 3. Touring the Interface
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● PID: the Process ID attribute value optionally assigned by the message contributor

● TID: the Thread ID attribute value optionally assigned by the message contributor

● Card: the Card ID attribute value optionally assigned by the message contributor

● Connector: the Connector ID attribute value optionally assigned by the message contributor

● Stream: the Stream ID value optionally assigned by the message contributor

● Level: the Level attribute value assigned by the message contributor

● Kind: the Kind attribute value assigned by the message contributor

● Trace: the text of the message body

● Comment: a user-editable data field

Display or hide a column

● To display a field, right-click the column headers and select the field you want to display.

● To hide a field, right-click the column headers and deselect the field you want to hide.

You cannot modify the column order.

Context menu

The following context menu appears when right-clicking in the message list:

● Auto resize Trace column: resizes automatically the Trace column to best fit the content.
Select to enable the option: a check mark is displayed in front of the menu option.

● Set time reference: sets the time reference +0:000000 on the current message in the Delta
field. See "Using Time Information" on page 66.

Memento User Guide 3. Touring the Interface
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● Inject current time trace: injects a message containing the UTC time and date in the ring
buffer. See "Using Time Information" on page 66.

● Copy: copies the content of the selected message to the clipboard. See "Saving Traces" on
page 60.

● Copy all: copies the content of all messages to the clipboard. See "Saving Traces" on
page 60.

● Copy same as: copies to the clipboard the content of all messages with the same description
in the Trace column as the currently selected message. See "Saving Traces" on page 60.

● Copy similar to: copies to the clipboard the content of all messages with a similar description
in the Trace column as the currently selected message. See "Saving Traces" on page 60.

● Bookmarks: gives access to the controls related to bookmarks (create, clear, jump to, select).
See "Defining Bookmarks" on page 33.

● Plot: allows you to represent selected messages in the message plot. See "Browsing Through
Traces" on page 27.

● Open Analyzer: allows you to extract the Analyzer traces to the viewer buffer and give access
to the Analyzer controls in the Memento GUI. See "Activating the Analyzer" on page 35.

● Analyze: gives access to Analyzer controls from the message list when the Analyzer
functionality is enabled and configured. See "Using Analyzer Tools" on page 42.

● Auto-Follow plot: shifts the message plot, without changing the zoom, to show the time frame
where the selected message is displayed. See "Searching for and Finding back Traces" on
page 30.

● Show keyboard shortcuts: opens the summary page with the list of keyboard shortcuts
available in the Memento GUI.

3.7. Status Bar

The Status Bar area of the Memento application displays:

● Traces: total # The total number of Memento traces that have been extracted to the viewer
buffer.

● Traces: history # The number of Memento traces that are currently available in the viewer
buffer.

● Delta time The time difference between the selected message and the time reference. This
value is also displayed in the delta column of the message list.

● Status The operating status – Running or Suspended – of the Memento application.

Memento User Guide 3. Touring the Interface
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4. Monitoring the Activity

You can monitor traces in real-time as they are added to the ring buffer, check older traces still
available in the ring buffer or analyze traces dumped to a log file.

The actions described in this chapter are also valid for message traces and Analyzer traces.
Otherwise, this is specified. See chapter "Analyzing Events" on page 35 for analyzing operations
specific to Analyzer traces.

4.1. Monitoring the Activity in Real Time
Default behavior

When you open the Memento application, the traces currently being added to the ring buffer
automatically start being extracted to the viewer buffer.

By default, the Memento traces are therefore instantly made available in the Memento
application and the most recent traces are displayed at the bottom of the message list.

This allows you to directly monitor the system activity in real time in the Memento application.

You can change the default behavior using the options Follow/Following and Pause/Run
available in the Control bar.

NOTE
The operations of injecting traces to the ring buffer, extracting traces to the
viewer buffer and displaying traces in the Memento application are based on
default filtering criteria applied to traces. These filters are configurable at
these three levels: injection, extraction and display. To change the filtering
criteria, refer to section "Setting up Trace Display" on page 46.

Enable/Disable trace update

● Set the Run/Pause button to Pause (enabled) to continuously extract the messages from the
ring buffer into the viewer buffer: the message list is dynamically updated with new
messages and the time is running out in the activity plot. This is the default behavior, which
allows real time activity monitoring.

● Set the Run/Pause button to Run (disabled) to stop extracting messages from the ring buffer
and filling in the viewer buffer: the message list is not updated and the time is stopped in the
activity plot.

Memento User Guide 4. Monitoring the Activity
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Display automatically most recent traces

● Set the Follow/Following button to Following (enabled) when you want Memento to
automatically scroll to the end of the message list and always display the most recent
traces.

This is the default behavior. As soon as you click a trace in the message list, the option
however shifts to Follow to keep the focus on the selected message.

● Set the Follow/Following button to Follow (disabled) when you do not want to change the
current display of messages.

To display the most recent messages in this mode, you need to scroll manually to the end of
the message list.

This option is mainly relevant when the Run/Pause option is set to Run.

4.2. Monitoring Earlier Stored Activity
Introduction

If a problem occurred some minutes ago in the production process, you can rapidly find back
the related traces and load them in the Memento application, as long as the traces are
available in the ring buffer. The Go Back function makes it possible to define the traces you
want to extract to the viewer buffer and load into the Memento application.

NOTE
The extraction process by the viewer buffer and the actual display in the
Memento application are based on default filtering criteria. If you want to
extract and/or display more or less information in the Memento application
when you perform a Go Back, you need to change the Verbosity filter and/or
Highlighting filters before you perform a Go Back action. See section "Setting
up Trace Display" on page 46.

Memento User Guide 4. Monitoring the Activity
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Go back to earlier stored traces

1. Click the Go Back button.

The Go Back dialog box appears:

2. In the Go Back Setup area, configure the Go Back action:

□ In the Rewind field, select how far in time or in positions from the most recent trace (in
the specified boot session) you want to rewind in the ring buffer.

□ In the Boot session field, select the Memento driver boot session (0=current, 1= previous,
...) that you want to extract traces from. This is only relevant with a Windows OS.

See Go Back setup options for more detailed information.

3. In the Go Back Options area, specify options for the Go Back action:

□ In the Limit amount of extracted traces field, select the number of traces (in the specified
boot session) you want to view starting from the rewound position.
The trace extraction will be paused each time the defined amount of traces has been
extracted.

□ In the Stop on matching filter, select the highlighting filter you want to use as a condition
to pause the trace extraction.
The trace extraction will be paused each time the condition defined in the highlighting
filter is met.

4. Click OK.

The message list is cleared, then filled in with the traces matching the Go Back definition.

If a Go Back option has been defined, the trace extraction is paused when one of the options is
met. Click Run to resume the trace extraction.

The message plot display is not modified. To get the overview on all traces extracted with the
Go Back option in the message plot, right-click in the message list and select Plot > All.

Memento User Guide 4. Monitoring the Activity
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TIP
If you go back as far as possible in the ring buffer and extract all traces to
the viewer buffer, all extracted traces might not be displayed in the message
list as the number of displayed traces depends on the maximum capacity of
the viewer buffer.

The data extraction mechanism indeed fills in the viewer buffer until the
most recent traces are displayed. As a consequence, the oldest messages will
not be displayed in the message list if the number of messages to be
displayed exceeds the maximum capacity of the viewer buffer.

It is therefore recommended to limit the amount of extracted traces if you
want to be sure to display the messages from the rewound position.

Go Back setup and options

Memento application – GUI mode – Go Back dialog box

Go Back setup

Rewind

This determines the time frame or number of positions to rewind in the Memento ring buffer
before starting to extract data.

Possible values are:

Value Description

As far as possible
Rewind as far as possible within the data of the specified boot
session.

1ms, 1s, 10s, 1m,
1m30s, 10m, 1h

Rewind 1 ms, 1s, etc. in time compared to the most recent trace in
the specified boot session.

Memento User Guide 4. Monitoring the Activity
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Value Description

10, 100, 1000, 10000,
100000

Rewind 10, 100, etc. positions compared to the most recent trace in
the specified boot session.

Boot session

This specifies the number of boot sessions to rewind to. This is only relevant in Windows.

Possible values are:

Value Description

0 Current boot session. Default setting.

1, 2, 3
…

Previous boot sessions, 1 being the more recent session (if still available in the
ring buffer).

Go Back options

Limit amount of extracted traces

This option specifies how many messages are to be extracted starting from the rewound
position in the Memento ring buffer.

By default, all traces of the specified boot session are extracted.

Stop on matching filter

This option specifies the highlighting filter to be used as a condition to pause the trace
extraction.

To be used in the Go Back option, the highlighting filter has to be defined in the Highlighting
Filters dialog box (See section "Customizing Trace Display" on page 50) but does not have to be
enabled. This option therefore works independently from the standard use of highlighting filters.

Continue button

It allows you to change one of the options and to continue the trace extraction without clearing
all messages in the message list.

Memento User Guide 4. Monitoring the Activity
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4.3. Loading Traces from a Dump File
Introduction

If you have previously saved the traces added to the ring buffer to a dump file, you can load the
dump file in the Memento application to view the saved data.

See the section "Saving Traces" on page 60 for detailed information on saving traces to a dump
file.

Load traces from a dump file

● Double-click the dump file and it will directly open in a new instance of the Memento
application.

NOTE
You can open a dump file that data is still being added to. In this case, the
Memento application will load the data available in the dump file when it
was opened. The data is not automatically refreshed. To view the most
recent data from the dump file, close the Memento application and reopen
the dump file in a new instance of the Memento application.

Memento User Guide 4. Monitoring the Activity
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5. Looking for Traces

This chapter describes all standard actions that will help you find back the traces relevant for
your investigations:

● focus on events in a specific time frame in the plot areas

● find back information in the message list based on a search

● adding bookmarks in the message list to easily identify given traces, etc.

5.1. Overview of Trace Display in Plots
Each message or Analyzer trace in the message list is represented visually in the message or
Analyzer plot.

Message trace display in the message plot

● The symbol = represents one or more message traces in the message plot depending on the
applied zoom.

● The symbols are displayed on horizontal lines. Each line corresponds to a verbosity level.

● The first line at the bottom represents the lowest verbosity level (verbose), the second line
represents the next verbosity level (debug), and so on up to the highest verbosity level
(critical).

● The symbols inherit the colors defined in the Highlighting Filters for the given verbosity level.
This corresponds to the font color in the message list.

See also "Message Plot" on page 15.

Analyzer trace display in the Analyzer plot

● Start trace: the waveform moving up one level indicates the corresponding process starts.

● Reset trace: the waveform moving down one level indicates the corresponding process stops.

● Counter trace: a vertical line, an empty rectangle or a value (depending on the zoom level)
displayed on a waveform means a value is issued in the corresponding process.

Memento User Guide 5. Looking for Traces
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See also "Analyzer Plot" on page 16.

5.2. Browsing Through Traces
Zoom in the plot

This procedure allows you to zoom in and out by changing the timescale in the message plot (or
Analyzer plot) in a general way.

1. Hover over the requested position in the message plot.

2. Rotate the mouse wheel up to zoom in and down to zoom out.

To zoom faster, press CTRL and rotate the mouse wheel as described in step 2.

Zoom on a specific portion of the plot

This procedure allows you to zoom in onto a specific portion of the message plot (or Analyzer
plot).

1. On the message plot, right-click the position you will start zooming from.

2. Drag the mouse to the right up to the position you want to stop zooming.

As you drag, a red rectangle is displayed showing the portion to be zoomed on:

When you release the mouse, the zoomed portion is stretched to the whole plot area.

Repeat this action to dig more precisely in the message plot or Analyzer plot.

Shift the time frame in the plot

When traces are available on the left or right of the time frame displayed in the message plot, a

red arrow appears on the left border or right border of the message plot (or Analyzer
plot).

● In the message plot, click and drag to the left or right to change the displayed time frame
keeping the same zoom level.
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Move up and down in the message list

Move rapidly up and down in the message list with the standard shortcut keys:

● PAGE UP to move up in the message list and display the previous set of messages.

● PAGE DOWN to move down in the message list and display the next set of messages.

● HOME or G to move to the top of the message list.

● END to move to the bottom of the message list.

● SHIFT + G to move to the bottom of the message list and set the Follow/Following option to
Following.

Display the plot for a set of traces

You can generate a plot corresponding to all traces of the current boot session, to the traces
displayed in the message list or to a selection of traces.

The procedures below describe the various ways to plot message traces in the message plot.
Similar controls are available to build graphs of Analyzer traces in the Analyzer plot.

Plot all traces of the current boot session

● Right-click in the message list and select Plot > All from the context menu.

The number of traces displayed is limited to the maximum capacity of the viewer buffer.

Plot the traces displayed in the message list

● Right-click in the message list and select Plot > View from the context menu.

Plot traces selected in the message list

1. Select the first message in the message list.

2. Scroll to the last message of your selection.

3. Simultaneously press SHIFT and click the last message to select all messages between the
first and the last.

4. Right-click the message list and select Plot > Selection from the context menu.

Plot traces between a selected message and a bookmark

This option is only available when at least one bookmark has been defined. See "Defining
Bookmarks" on page 33.

1. Click the message that you want to view the plot from/to.

2. Right-click, then select Plot > From/To bookmark and the requested bookmark name.
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Plot traces between two bookmarks

This option is only available when two bookmarks have been defined. See "Defining
Bookmarks" on page 33.

● Right-click in the message list, select Plot > Between bookmark and the boundary bookmarks
in the subentries of the context menu.

NOTE
To build graphs of Analyzer traces, proceed similarly using the Analyze item
in the context menu of the message list, and the corresponding subitem.
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5.3. Searching for and Finding back
Traces
Search for traces based on the Trace field content

To search for messages including a specific text string in the Trace column, proceed as follows:

1. Click the Search field in the Control bar and type the requested text string.

2. When applicable, select one of the search options:

□ Aa check-box to take into account the upper and lower cases in the entered text string.

□ RE check-box to specify you have used the Perl-like regular expression syntax in the
Search field.

3. To search for the entered string,

□ press F3 to search down.

□ press SHIFT + F3 to search up.

Speed up your searches using keyboard shortcuts

The following shortcuts are available to speed up the search process:

In order to ... Proceed as follows:

To enable the Search field ... Press /.

To copy a trace from the message list to the Search
field ...

Select the trace in the message list
and press Y.

To repeat the last search you performed in the
message list ...

This does not necessarily corresponds to the last
search criteria entered in the Search field.

Press F3 or N to search down in the
message list.

Press SHIFT+F3 or SHIFT+N to
search up in the message list.
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Search for traces having identical or similar content

When you identify a specific trace and want to find back other traces having the same or a
similar description in the Trace field, or the same kind, level, PID or TID, you can perform such
searches directly in the message list, without using the Search field.

By traces having a similar description in the Trace field, we mean traces having the same fixed
frame but possibly different values for the optional arguments.

1. In the message list, identify the message having the content (value in Trace, Kind, Level, PID
or TID field) you want to search for.

2. In this message, click the field with the value you want to search for.

3. Press the following keyboard or keyboard combination:

□ To search downwards for traces having the same content, press J (or * in the numeric
pad).

□ To search upwards for traces having the same content, press SHIFT + J (or SHIFT + * in
the numeric pad).

□ To search downwards for traces having a similar content, press S (or - in the numeric
pad).

□ To search upwards for traces having a similar content, press SHIFT + S (or SHIFT + - in
the numeric pad).

Find back bookmarked traces

When you have assigned bookmarks to traces, you can easily find such traces back in one of the
following ways. See "Defining Bookmarks" on page 33.

The bookmark names are specified in the Comment column.

● In the message list, right-click and select Bookmarks > Jump to and the bookmark name.

● In the Search field, type the bookmark name or part of it and press F3.

Find back a trace from the message list in the plot

To directly find back, in the message plot (or Analyzer plot), a trace you have identified in the
message list, proceed as follows:

1. In the message list, right-click and enable the option Auto-Follow plot.

2. In the message list, click the trace you want to find back in the plot.

The current position marker (yellow vertical bar) is displayed in the plot area to represent the
position of the selected message.

If necessary, the message plot shifts to show the relevant time frame.
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NOTE
Enabling the Auto-Follow option might degrade the performances when
many traces are generated. It is therefore recommended to disable the
option when you do not need it.

Find back a trace from the plot in the message list

To directly find back, in the message list, a trace you have identified in the message plot (or
Analyzer plot), proceed as follows:

● Press CTRL and click on the trace symbol in the plot area.

In the message list, the Trace field of the corresponding trace is displayed in a black frame:

Copy a tooltip to the clipboard

The Tooltip area displays the information corresponding to the mouse cursor position. It is thus
dynamically updated.

1. Position the mouse cursor on the requested trace in the message plot.

The corresponding tooltip is displayed in the Tooltip area.

2. Press SHIFT to freeze the tooltip message in the Tooltip area.

3. Drag the mouse cursor to select the tooltip text.

4. Right-click and select Copy from the context menu.

The tooltip text has been added to the clipboard. You can paste it wherever you want.
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5.4. Defining Bookmarks
Bookmark Use

Once bookmarks are created, they will help you perform a series of actions:

● Find bookmarked traces

● Plot traces using bookmarks as start and/or end boundaries

● Create a dump file of traces between bookmarks

● Display time interval between two bookmarks

etc.

WARNING
Bookmarks are lost when you close the Memento application.

Add a bookmark

1. In the message plot, select the trace you want to add a bookmark to.

2. Do one of the following actions:

□ Right-click and select Bookmarks > Toggle.

□ Press F4.

In the message list:

● The bookmarked trace is highlighted on a light blue background.

● A default bookmark name is added in the Comment column for this trace.

The default bookmark name bkm X where X is a incremented number starting from 0

In the message plot:

● The bookmarked trace is represented by a blue marker with the default bookmark name.
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Clear bookmarks

Clearing a bookmark disables the bookmark so that it is no longer highlighted in the message
list nor displayed in the message plot. It is no longer available in the various options where you
can use them.

Clearing a bookmark does not remove the default bookmark name in the Comment column. You
need to clear the name manually in the Comment column.

To clear all bookmarks

● Right-click in the message list and select Bookmarks > Clear all.

To clear a single bookmark

1. Select Bookmarks > Jump and the bookmark name.

2. Press F4 or select Bookmarks > Toggle.

Edit the bookmark name

When created, the Memento application assigns a default name to each bookmark: bkm
followed by an incremented number.

To edit the bookmark name, proceed as follows:

● In the message list, click the bookmark name in the Comment column and type the
requested name.
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6. Analyzing Events

This chapter explains how to enable, configure and use the Analyzer functionality in the
Memento application.

6.1. Activating the Analyzer
Introduction

Thanks to the Analyzer functionality, events and state changes in the various steps of the
digital image acquisition process can be represented as waveforms in a specific Analyzer plot,
below the message plot.

By default, the Analyzer functionality is not active in the Memento application. You need to
enable and configure it as described below:

1. From the Menu button, select Enable analyzer to allow the extraction of the Analyzer traces
to the viewer buffer and give access to the Analyzer controls in the Memento application.

2. From the Menu button, select Open analyzer to open the Analyzer Configurator window and
the Analyzer plot in the main window.

3. In the Analyzer Configurator, define which Analyzer waveforms you want to display in the
Memento application. See "Configuring Traces for Analysis" on page 38.

When the Analyzer has been configured, the selected Analyzer waveforms appear in the
Analyzer plot.

4. From the Menu button, select Show analyzer traces  to show, in the message list, Analyzer
traces that correspond to the events displayed in the Analyzer plot area.

The Analyzer traces will be displayed in the message list for all the events that will occur
after you have selected this option.
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6.2. Overview of the Analyzer
Configurator
The Analyzer Configurator allows you to select the types of events or state changes you want to
display as Analyzer waveforms in the Analyzer plot.

See "Configuring Traces for Analysis" on page 38 for more information on the configuration.

Click the Menu button in the Control bar and select Open Analyzer to open the Analyzer
Configurator window. This option is only available if you have previously selected Enable
Analyzer via the Menu button.

(1) Menu bar

The Menu bar includes the following menus and menu items:
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● Edit menu: to select and deselect all trace kinds and contexts available in the Profiles or
Advanced tab.

● View menu: to refresh the window.

● Analyze menu: to plot a set of traces in the Analyzer plot:

□ all Analyzer traces with Analyze > All

□ the Analyzer traces displayed in the message list with Analyze > View

□ the Analyzer traces selected in the message list Analyze > Selection

The Analyze menu corresponds to the Analyze > All / View / Selection available in the context
menu of the message list.

(2) Tabs

● The Profiles tab allows you to select which Analyzer waveforms you want to be available in
the Memento application.

● The Advanced tab allows you to refine the selection of the Analyzer waveforms, change the
name or the color of the waveforms in the Analyzer plot.

This tab is not described as the Profiles tab provides enough selection criteria.

(3) Profile tab - Kinds area

The Kinds area allows you to perform a first selection, based on the kinds, of the Analyzer
waveforms you want to display in the Analyzer plot.

The kinds provide a classification based on the nature or origin of the messages – for example
messages related to the firmware, to an API, to the communication between components, etc.

The Kinds area displays only the kinds having Analyzer traces available in the ring buffer.

(4) Profile tab - Contexts area

The Contexts area allows you to perform a more refined selection of the Analyzer waveforms
you want to display in Analyzer plot.

For each kind selected in the Kinds area, the selection in the Contexts area allows you to define
the driver, card, connector (and possibly stream) you want to display the Analyzer waveforms
for in the Analyzer plot.

(5) Profile Tab - Waveforms area

The Waveforms area show the Analyzer waveforms resulting from the selection in the Kinds and
Contexts areas.

In this area, you can further remove and reorder the waveforms individually.

These waveforms will appear in the Analyzer plot.
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6.3. Configuring Traces for Analysis
You can configure which Analyzer waveforms you want to display in the Analyzer plot using the
Analyzer Configurator.

See the section "Overview of the Analyzer Configurator" on page 36 for a general description.

WARNING
Once you have configured the waveforms you want to view in the Memento
application, you need to keep the Analyzer Configurator window open for
the Analyzer plot to be displayed in the main window.

Accessing the Analyzer Configurator

1. If you have not enabled the Analyzer yet, click the Menu button and select Enable
analyzer.

2. From the Menu button, select the Open Analyzer control.

The Analyzer Configurator window opens.

Select the Analyzer waveforms

To select the Analyzer waveforms you want to display in the Analyzer plot, proceed as follows in
the Analyzer Configurator:

1. In the Kinds area, select the kinds that you want Analyzer traces to be available for in the
Memento application.

2. In the Kinds area, highlight a selected kind. In the Contexts area, select the waveforms
(driver, card, connector and stream) you want to be available for this kind.
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All Analyzer waveforms corresponding to the selected kinds and contexts are displayed in the
Waveform area at the bottom of the Analyzer Configurator window.

TIP
To delete an individual waveform directly in the Waveforms area below,
click the waveform and press Delete.

Reorder Analyzer waveforms

The order of the waveforms in the Analyzer plot corresponds to the order defined in the
Waveform area at the bottom of the Analyzer Configurator window.

● To change the position of a waveform, click the waveform name in the Waveform area and
drag it to the requested position.

Display Analyzer traces in the message list

By default, the Analyzer traces are only displayed in the Analyzer plot. You need to activate an
option to see the corresponding messages in the message list:

1. In the main window, click the Menu button in the Control bar.

2. Select Show analyzer traces in the displayed menu.

The messages corresponding to Analyzer traces are displayed in the message list from then on.

These traces start with the event descriptor: [Counter],[Start]or [Reset].
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6.4. Modifying the Analyzer Trace Display
Default display of Analyzer waveforms

The default display settings for the Analyzer plot are the following ones:

● The timescale views on the Analyzer plot and the message plot are not tied to each other.

● The name of the waveforms is displayed on the left of the Analyzer plot.

● The counter values in the Analyzer plots are displayed in the decimal numbering system.

Modify the default display settings

Some parameters are available to modify the default display of Analyzer waveforms. Most
parameters are available in the context menu available from the message plot.

They are highlighted in the screenshot below:
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Hide the waveform name

By default, the name of the waveforms is displayed on the left of the Analyzer plot.

To hide the waveform name in the Analyzer plot and show the plot information on the full
timescale length:

● Right-click the message list and select Analyze > Show plot info from the context menu.

The name of the waveforms is now hidden. You can reactivate it in the same way.

Display values in hexadecimal notation

By default, the counter values on waveforms are displayed using the decimal notation.

To display the counter values in hexadecimal notation:

● Right-click the message list and select Analyze > Show hexadecimal values from the context
menu.

Use an alias for the waveform name

To customize the waveform names in the Analyzer plot, proceed as follows:

1. In the Analyzer Configuration window, select the Advanced tab.

2. Identify the waveform you want to assign an alias to.

3. Click the cell to the right of the Alias field and type the requested alias.

The waveform name will be adapted in the Analyzer plot.

Modify the color of a waveform

1. In the Analyzer Configuration window, select the Advanced tab.

2. Identify the waveform you want to change the color of.

3. Click the More button to the right of the field displaying the color.

The Color dialog box opens

4. In the Color window, select a color in the basic colors or type the RGB / HSL color
coordinates and click OK to validate.

The waveform color is automatically adapted in the Analyzer plot.
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6.5. Using Analyzer Tools
Available standard tools

Most actions available for message traces in the message plot are also available for Analyzer
traces in the Analyzer plot. This is explicitly specified in the relevant procedures:

● "Browsing Through Traces" on page 27

● "Using Time Information" on page 66

When the description of Analyzer traces is displayed in the message list (see "Display Analyzer
traces in the message list" on page 39), you can search for these traces as described in the
section "Searching for and Finding back Traces" on page 30.

Display the Analyzer graph for a set of traces

You can build a graph of Analyzer traces in the same way as you can plot the message traces.
Similar controls are available, as well as controls that imply the use of bookmarks.

You can access the various controls for building Analyzer graphs in the context menu of the
message list, from the Analyze menu.

These controls are highlighted in the screenshot below:

See the section "Display the plot for a set of traces" on page 28 for procedures on how to use
these controls.
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Plot current analyze view

When the Link views option is disabled and both message plot and Analyzer plot show different
time frames, you can rapidly plot the message traces in the message plot based on the time
frame displayed in the Analyzer plot:

● Right-click in the message list and select Analyze > Plot current analyze view from the
context menu.

Example

In the initial situation, the Analyzer plot covers a time frame of around 100 ms (around
146800.000 ms) whereas the message plot shows a time frame of about 4 minutes (from 0m to
4m).

When you request Memento to plot the current analyze view, it builds a plot in the message
plot that spans over the time frame displayed in the Analyzer plot (100 ms around 146800.000
ms):
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Analyze current plot view

When the Link views option is disabled and both message plot and Analyzer plot show different
time frames, you can rapidly build waveforms in the Analyzer plot based on the time frame
displayed in the message plot:

● Right-click in the message list and select Analyze > Analyze current plot view from the
context menu.

Example

In the initial situation, the Analyzer plot covers a time frame of about 3 m (from around 1m to
4m) whereas the message plot shows a time frame of about 1s (from 1m 34ms to 1m 35s).

When you request Memento to build a graph of the current plot view, it spans the waveforms in
the Analyzer plot over the time frame of about 1s displayed in the message plot (from 1m
34ms to 1m 35s):
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Measure the events between bookmarks

You can measure the number and frequency of events over a given time frame for all displayed
waveforms:

1. Set two bookmarks to identify the time frame that you want to analyze the events in:

a. Press CTRL and click on an event in the Analyzer plot to set the position for a new
bookmark.

b. Press F4 to add the bookmark.

c. Repeat both previous actions to define a second bookmark.

2. Right-click in the message list to open the context menu.

3. Select Analyze > Measure between bookmarks as well as the boundary bookmarks in the
context menu.

The number and the frequency of events over the defined time frame are displayed on the right
hand of the Analyzer plot, as highlighted in the screenshot below:

Call up the previous trace

To call up the previous trace on a waveform and display it at the cursor position in the Analyzer
plot:

● Position the mouse cursor on a given waveform around the position you are searching for
events and middle-click the mouse.

The waveform will shift and display the previous trace on that waveform.
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7. Setting up Trace Display

This chapter explains how you can modify, at the three levels specified below, the default
settings for filtering and/or displaying the traces :

● filtering before adding traces into the ring buffer

● filtering before adding traces to the viewer buffer

● hiding or highlighting traces directly in the Memento application

7.1. Filtering Traces in the Ring Buffer
Initial ring buffer Configuration

The ring buffer configuration (also called Memento configuration) consists in filtering, by means
of ring filters, the traces to be added to the ring buffer for the various kinds of traces.

A default ring buffer configuration is applied. It is displayed in the screenshot below and
explained in the section Setting up the Driver in the Getting Started Guide (D602).

You can modify the default ring buffer configuration before starting the Memento application.
See Change the configuration in the Getting Started Guide (D602).

You can still change the ring buffer configuration settings in the Memento application, via the
Ring Filters button available in the Control bar.

NOTE
If you change the ring filters in the Memento application, the new filters will
be applied for all future messages that will be added to the ring buffer.
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Ring Filters dialog box

To view the current ring buffer configuration, click from the Control bar.

In the Ring Filters dialog box, you specify that all messages of a given kind and with at least a
given verbosity level must be added to the ring buffer.

The messages that do not meet the filtering criteria will not be added to the ring buffer. You will
never be able to view such messages in the Memento application.

For example

Looking at the screenshot above, you can see that:

● The CoaxPress filter is defined with verbosity level Debug: all messages linked to the
CoaxPress kind and having at least the verbosity Debug (that is Debug, Info, Notice,
Warning, Critical) will be added to the ring buffer. For this kind, the Verbose messages will
be disregarded.

● The Default filter applies to all kinds not explicitly defined in the Ring Filter dialog box. In
this case, all messages will be added for these kinds as the defined verbosity level is
Verbose.
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Filter traces in the ring buffer

You can access all controls to refine the ring buffer filters by clicking on the Control
bar, and right-clicking to access the context menu:

NOTE
You cannot modify the ring buffer configuration when a dump file is open in
the Memento application even the dump file is being fed with new traces
from the ring buffer.

Change the verbosity level for a kind

Kind available in the list

1. Right-click the requested kind to access the context menu.

2. Select Set level and the requested verbosity level.

Kind not available in the list

This means the Default verbosity level is applied to this kind:

1. Right-click to access the context menu.

2. Select Add kindand the requested kind from the context menu.

3. Right-click the kind, then select Set level and the requested verbosity level from the context
menu.

Reset a kind to the default verbosity level

1. Right-click the requested kind to access the context menu.

2. Select Remove kind from the context menu.
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Apply a profile

1. Right-click to access the context menu.

2. Select Load profile and the requested profile.

Save the current configuration to a file

1. Right-click to access the context menu.

2. Select Save.

3. In the Save memento ring filters dialog box, select the folder where you want to save the
configuration file and click Save.

By default, the configuration file has the following name: filters.memento-config

Use the menu item Load to find back a previously saved configuration and apply it back.

Exclude Analyzer traces from the ring buffer

By default, the Analyzer traces are added to the ring buffer.

To prevent the Analyzer traces from being added to the ring buffer:

1. Right-click to access the context menu.

2. Click Analyzer.

The option is deselected in the context menu and the Analyzer traces are no longer added to the
ring buffer.

7.2. Filtering Traces for the Viewer Buffer
Verbosity Filter

In the Memento application, you use the Verbosity Filter to define the traces to be extracted to
the viewer buffer based on their criticality. The traces extracted to the viewer buffer are
displayed by default in the Memento application.

The verbosity filter allows you to display only the messages having a verbosity level (level
attribute) equal to or greater than the defined verbosity level.

By default, the verbosity filter is set to Notice: all traces having the verbosity Notice, Warning,
Error or Critical are displayed in the Memento application.

NOTE
When you change the verbosity filter in the Memento application, the new
rules are applied to extract subsequent traces.

See the section Verbosity Filter in the Getting Started Guide (D602) for a detailed description of
the verbosity filter.
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Display the current verbosity level

The Verbosity Filter is available as a slider in the Control bar.

● Hover over the slider to display the current verbosity level taken into account for trace
filtering in the viewer buffer.

Restrict or Broaden the traces to be extracted to the viewer buffer

● To restrict the number of traces to be extracted to the viewer buffer, move the Verbosity
Filter slider to the left up to the requested verbosity level.

● To increase the number of traces to be extracted, move the Verbosity Filter slider to the right
up to the requested verbosity level.

The verbosity level is displayed when you keep the mouse cursor on a slider position.

Once you have modified the verbosity filter, the new filtering rule is instantly applied to extract
subsequent traces.

NOTE
If you want the same verbosity rules to be applied to all messages in the
viewer buffer once have changed the verbosity filter, you need to clear the
viewer buffer using the Clear button and perform a Go Back to regenerate
the viewer buffer.

7.3. Customizing Trace Display
Highlighting filters

By default, all the traces extracted to the viewer buffer are displayed in the Memento
application.

Using the Highlighting Filters, you can customize the display of the filtered message traces in
order to:

● highlight the set of traces that meet (or do not meet) the filtering criteria.

(and/or)

● change the font color of traces that meet (or do not meet) the filtering criteria.

(or)

● hide the traces that meet the (or do not meet) the filtering criteria.
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Each highlighting filter has two sets of controls:

● The controls for the filter rule that select a specific set of messages.

● The controls for the filter action that define the actions to be performed on the selected set
of messages.

NOTE
The Highlighting Filters are applied to all messages displayed in the Memento
application. In other words they apply also to messages that would already
have been available in the user interface before you modify the Highlighting
Filters.

Working principles

● Sixteen Highlighting Filters are available in the Memento application.

● Only enabled filters are taken into account.

● When a trace meets a filter rule, the layout options for that filter are applied. Subsequent
filters are disregarded for this trace.

● The Memento application parses the filters from filter 1 to filter 16.

● By default, the filters from 11 to 16 are enabled. Each of them is configured to apply
predefined layout options for a given verbosity level.

● As a consequence, a user-defined filter (1 to 10) has priority over the default filters (11-16).
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Highlighting Filters dialog box

To access the Highlighting Filters, click from the Control bar:

(1) Filter Number field

The Filter field allows you to select the filter number you want to set up.

When a filter is selected, all other fields in the dialog box allow you to set up the selected filter.

(2) Enable field and Polarity field

Enabled field

The Enable control allows you to enable/disable each filter individually while keeping the other
filter settings unchanged.

When the Enable control is not selected, the highlighting filter is not applied.

Polarity field

The Polarity control determines whether or not the action has to be executed when all the
enabled filtering criteria are True:

● When unselected, the action is executed only when all the enabled filtering criteria are True.

● When selected, the action is always executed except when all the enabled filtering criteria
are True.
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(3) Filtering criteria

These fields allow you to define the filtering criteria for the selected filter.

Six filtering criteria are based on attribute values and one filtering criterion is based on the
content of the message trace:

Filtering criteria based on attribute value

A filtering criterion is available for each of the following message attributes: Level, Kind, PID,
TID, Card, Connector.

Each criterion has an Enable control and a value.

The criterion is only taken into account when the Enable control is selected (and when the
corresponding filter is also enabled).

The filtering criterion is evaluated to True when the attribute value of a message matches the
value defined in filtering criterion.

Filtering criterion based on message content

One filtering criterion is based on the content of the message. It has an Enable control and a
text string value.

The filtering criterion is only taken into account when the Enable control is selected (and when
the corresponding filter is also enabled).

The filtering criterion on the message content is evaluated to True when the message body
contains the specified text.

(4) Filter Action fields

The action of an highlighting filter is defined using the following fields:

● A Hide control

● A Background Color selector

● A Font Color selector

Hide control

The Hide check-box determines whether or not messages matching the filter rule have to be
hidden.

This option applies to the messages in the message list and to the trace display in the message
plot.

When the Hide check-box is selected, the messages matching the filter rule are hidden.

When the Hide check-box is unselected, the messages matching the filter rule are displayed
using the selected font color and/or background color.

By default, the Hide check-box is unselected.
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Background and font color selectors

The Background field and Color field offer a set of basic and custom colors to respectively
highlight the message and/or change the font color of the message in the message list. Both
actions can be applied simultaneously.

The Background option impacts the highlighting color of the trace message in the message list
and the color of the trace display in the message plot.

The Color field only impacts the font color of the Trace field in the message list.

By default, the message in the message list is displayed:

● in black font

● on a white background

(5) Filter Management fields

The Filter Management fields allow you to perform the following actions:

Click
... in order to ...

Save
save the entire Highlighting Filter configuration to a file called filters.memento-

filters by default.

Load load a previously saved configuration file.

Default reset the entire Highlighting Filter configuration to the default configuration.

Apply
apply the current configuration defined to the data displayed in the Memento
application.

Revert
cancel the changes defined since the last time you applied the changes (using the
Apply button).

Default Configuration

By default, the highlighting filters are configured as follows:

Filter # Filter Rule Filter Action

1 to 10 Disabled

10 Level=User Highlight – Green text | white background

11 Level=Error Highlight – Black text | red background

12 Level=Warning Highlight – Black text | orange background

13 Level=Notice Highlight – Green text | white background

14 Level=Info Highlight – Purple text | white background

15 Level=Debug Highlight – Grey text | white background

16 Level=Verbose Highlight – Light Grey text | white background
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Customize the trace display

1. In the Control bar, click to display the Filters dialog box.

The dialog box opens on the definition on the configuration of the highlighting filter #1.

2. In the Filter drop-down box, select the filter you want to customize.

By default, only the filters 11 to 16 are enabled and implement the default highlighting
scheme.

3. Select the Enable check-box to enable the filter.

4. If requested, invert the filter rule by selecting the Not check-box:

□ When the check-box is not selected, the filter action is executed only when all the
enabled filtering criteria are True.

□ When the check-box is selected, the action is always executed except when all the
enabled filtering criteria are True.
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5. For each filtering criteria you want to apply:

□ Select the check-box in front of the filter criteria.

□ Type or select the value to be used as filtering criterion.

See "(3) Filtering criteria" on page 53 for more information.

6. Define the action(s) to be performed when the filter rule is met.

See "(4) Filter Action fields" on page 53 for more information.

7. Click Apply to apply the filters to the data displayed in the Memento application.

A number is added onto the Highlighting Filters button to show how many filters have been
customized:
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Example 1

In this example, the traces having the verbosity level Verboseand the kind Acquisition will be
highlighted in light blue in the message list and the trace symbol in the same color in the
message plot. The font color of the message in the message list remains black.
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Example 2

In this example, the traces having all but the Acquisition kind will be highlighted in light blue in
the message list and the corresponding trace symbol in the same color in the message plot. The
traces having the Acquisition kind will not be highlighted.
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Example 3

In this example, the traces having all but the Acquisition kind are hidden in the message list,
and the corresponding trace symbols will be hidden in the message plot. The traces having the
Acquisition kind are displayed with the default background color (white) and font color (black).

Increase or decrease the font size in the message list

To increase the font size, use one of the following keyboard combinations:

● Press Z

● Press CTRL + + (in the numeric pad)

To decrease the font size, use one of the following keyboard combinations:

● Press SHIFT + Z

● Press CTRL + - (in the numeric pad)
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8. Saving Traces

Purpose for saving traces

You can save traces from the ring buffer to a dump file mainly for backup or investigation
purposes:

● You want to back up all traces added to the ring buffer.

In this case, you will continuously record the traces into one dump file, or several smaller
ones. Doing this, you do not run the risk of losing the traces that will be overwritten in the
ring buffer.

See "Save all traces to a dump file" on the next page.

● You want the Euresys Support team to investigate a past issue or an issue you have
reproduced.

In this case, you create a dump file that includes all events stored in the ring buffer and
located around the past or reproduced issue.

See "Save selected traces to a dump file" on page 63.

You can also copy and save traces into a spreadsheet for your own records. However, the dump
file remains the most appropriate source of information for the Euresys Support team to
investigate issues.

NOTE
The dump file includes all the traces added to the ring buffer from a given
time point or position in the ring buffer. This does not take into account the
verbosity filter and highlighting filters as they are applied after the ring
buffer in the message flow.

Start quickly saving traces

Without opening the Memento application, you can start saving the data added subsequently to
the ring buffer into a dump file as follows:

● From the Windows Start menu, select the command Euresys Memento > Start Memento
Logging.

When you select this option, the Memento application:

● creates a dump file dumXXXX.memento saved to %USERPROFILE%\memento\ where XXXX is
an automatically generated alphanumeric string.

● opens a command line window that displays the dump file size.
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● feeds the dump file continuously with the subsequent data from the ring buffer as long as the
command line window remains open.

Save all traces to a dump file

To start backing up existing and/or future traces to a dump file as of now and/or from a given
time or position in the past, proceed as follows:

1. In the Control bar, click and select Dump memento data to file.

The Dump dialog box opens:

2. In the Dump Setup area, specify the traces you want to dump.

See the section "Dump Setup options" on the next page for more details.

3. In the Dump Rotation Setup area, specify how to split the dump file and whether to delete
older dump files.

See the section "Dump Rotation Setup options" on the next page for more details.

4. If requested, change the default location for saving the dump files by clicking Browse in the
File Setup field.

5. Click Start to start saving the traces to the dump file.

The dump file is created by default in the Memento application directory
%USERPROFILE%\dump.memento\ or in the folder specified in step 4.

As long as the dump file is open, you can stop saving to the dump file by clicking the Stop
button displayed instead of the Start button in the dialog box.

Memento User Guide 8. Saving Traces



62

Dump Setup options

Rewind

The Rewind option determines the number of positions or minutes to rewind in the ring buffer
before starting to dump traces.

Possible values are:

Value Description

No No rewind. Default setting.

As far as possible
Rewind as far as possible within the data of the specified boot
session.

1s, 1m, 1h
Rewind 1 second, 1 minute, 1 hour back within the data of the
specified boot session.

10, 100, 1000, 10000,
100000

Rewind 10, 100, 1000, 10000, 100000 positions.

Boot session

The Boot session option specifies the number of boot sessions to rewind to.

Possible values are:

Value Description

0 Current Boot Session Default setting.

1, 2, 3
…

Previous boot sessions. 1 is the previous session the closest in time.

This is only available with Windows when data from previous sessions are still
available in the ring buffer.

This is not available with Linux OS and macOS.

Dump Rotation Setup options

Split size in MB

The Split size in MB option allows you to split the dumped data over multiple files by specifying
a size limit.

Possible values are:

Value Description

No Split One file per dump session. Default setting.

256, 512,
1024

Allows the dump file to be split into multiple files having a maximum size of
respectively 256, 512 or 1024 Megabytes
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Keep

The Keep option allows to limit the number of dump files to keep.

Possible values are:

Value Description

All Keeps all dump files. Default setting.

10 Keeps only the 10 most recent dump files.

File Setup option

This option allows you to select another file name and location.

The default file name is: dump.memento.

The default file location is %USERPROFILE%\dump.memento\.

The Memento application keeps previous dump files in the same directory by assigning a
numerical suffix to their name. Assuming the file name is set to dump.memento, older files are
named dump.1.memento, dump.2.memento, dump.3.memento, etc.

Every time a new dump file is created, the Memento application:

● increments the numerical suffix of all existing dump files (file name rotation).

● renames the previous dump file by adding the '.1' suffix.

TIP
Euresys recommends to keep the filename suffix .memento.

Save selected traces to a dump file

To save only a selection of traces to a dump file to be sent for investigation, you can select
directly the requested traces in the message list or use bookmarks for the selection:

Save traces selected manually to a dump file

1. In the message list, select the first message to save into a dump file.

2. Scroll to the last message to be selected and press CTRL + SHIFT to select all messages
between the first and the last.

3. In the Control bar, click and select Dump memento selection to file from the menu.

4. In the Dump memento to file window, select the folder where you want to store the dump
file and edit the name, if requested (keep the .memento extension).

5. Click Save.

The dump file includes the content of the ring buffer between the time stamps of the first and
last selected messages.
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Save traces selected between two bookmarks to a dump file

This option is only available when at least two bookmarks have been defined. See "Defining
Bookmarks" on page 33.

1. In the Control bar, click and select Dump memento section between bookmarks from the
menu, and the bookmarks to be used as boundaries for the dump file.

2. In the Dump memento to file window, select the folder where you want to store the dump
file and edit the name, if requested (keep the .memento extension).

3. Click Save.

The dump fill includes the content of the ring buffer between the time stamps of the selected
bookmarks.

Copy messages to the clipboard

To further process messages from the message list, you can copy them to the clipboard and
save them to a spreadsheet or text file.

Either you select and copy several messages or you select a single message and request
Memento to find back the same or similar messages in the message list:

Copy a selection of messages

1. Click the first message of your selection in the message list.

2. Scroll to the last message and simultaneously press SHIFT and click the last message to
select all messages between the first and the last.

3. Right-click and select Copy from the context menu.

Copy all displayed messages

● Right-click and select Copy all from the context menu.

Copy all occurrences of the same message or similar messages

1. In the message list, click the message that you want to copy all identical or similar
occurrences of.

2. Right-click and select on of the following options from the context menu:

□ Copy same as: copies to the clipboard the content of all messages with the same
description in the Trace column as the currently selected message.
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□ Copy similar to: copies to the clipboard the content of all messages with a similar
description in the Trace column as the currently selected message.
Similar messages are messages where only the attribute values may differ compared to
the selected message.

Once the messages are copied to the clipboard, simply paste them to the requested application.
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9. Using Time Information

You can use the following tools to get additional time information related to the traces:

Change the time reference

In the message list, the Delta field value is used as the time reference. By default, the first trace
displayed message list gets the time reference +0.000000 (with microseconds precision) whether
the viewer buffer is read in real-time monitoring or using the Go Back function.

If the number of traces to be displayed exceeds the maximum capacity of the viewer buffer
(250000 entries), the first visible trace might have a different time reference.

To set the time reference to another message than the first displayed message, do one of the
following actions:

● Right-click the message to be assigned the time reference and select Set time reference
from the context menu.

● Click the message to be assigned the time reference and press T from the keyboard.

Measure time interval between two traces

● Press SHIFT and simultaneously click and drag the mouse between both traces to measure
the time interval.

The red line symbolizes the calculated time interval displayed in orange.

TIP
The time interval between two bookmarks is automatically displayed on the
message plot when allowed by the zoom level.
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Inject current timecode in the ring buffer

A message containing the current UTC date and time of kind Time and the verbosity level Notice
is inserted at regular intervals into the ring buffer. This provides a sync point between the
Memento time scale and the system time, itself possibly synchronized to an Internet Time
Server.

When you are monitoring the process in real time, you can also inject manually such a message
in the ring buffer:

● Right-click the message list and select Inject current time trace from the context menu.
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10. Administration Tools

The following administration tools are available from the Menu button in the Control bar:

● Clear search history to clear the history of the search strings in the Search field.

● Clear all user preferences to clear the history of all user preferences (verbosity filter, layout
preferences, etc.). The Ring filter and Highlighting filters are not reset with this control.

● Clear Analyzer preferences to clear the Analyzer configuration.

● Clear history before bookmark to clear the message list before the selected bookmark
(available when at least a bookmark is defined).
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11. Appendix 1 - Keyboard
Shortcuts
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12. Glossary

A

ACTIVITY PLOT
Area in the Memento application (GUI) that displays a plot of the number of
Memento traces recently added to the Memento ring buffer. In other words, this
shows the recent activity of the Memento contributors.

ANALYZER PLOT
Area in the Memento application (GUI) that displays waveforms representing events
and state changes occured over a time frame in selected steps of the image
acquisition process.

ANALYZER TRACE
Memento traces that can help users analyze, detect and understand issues during
system component discovery and defects during image acquisition. Such traces are
displayed in the Analyzer plot.

H

HIGHLIGHTING FILTERS
Set of filters allowing users to customize the display of the Memento traces in the
Memento application.

M

MEMENTO APPLICATION
User interfaces of the Memento system. The Memento application is available in two
modes: a Console mode allowing users to interact with the Memento system in
command line, and the GUI mode allowing users to interact with the Memento
system via a graphical user interface.

MEMENTO CONTRIBUTOR
Frame grabber driver and library, or user space application that inject event
messages to the Memento ring buffer
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MEMENTO MESSAGE
Event-related data record in the Memento application including a message body
(text string that described the event) and message attributes (data related to the
event)

MEMENTO TRACE
Message and graphical representation, in the Memento application, of an event or
information written by a Memento contributor in the Memento ring buffer.
Memento generates a Memento trace by mapping the event data injected by the
Memento contributor with the corresponding message stored in the Memento
dictionary. A Memento trace also refers to the event data generated by a software
macro executed on the Memento contributor side and injected into a message slot
of the Memento ring buffer.

MESSAGE KIND
Classification of Memento traces based on their nature or origin

MESSAGE LIST
Area in the Memento application (GUI) that displays a filtered set of Memento
messages.

MESSAGE PLOT
Area in the Memento application (GUI) that displays a plot showing the message
traces issued over a time frame based on their severity.

MESSAGE TRACE
Memento traces providing log information that can help users detect issues in the
image acquisition process. Each message trace has a given origing (kind) and
severity (verbosity). Such traces are displayed in the message plot.

R

RING BUFFER
Common memory space reserved by the Memento driver on the computer, in which
the Memento contributors inject event data.

RING FILTER
Filter used to define the traces to be added to the Memento ring buffer based on
their kind and the requested verbosity level.

V

VERBOSITY FILTER
Filter used to define the traces to be extracted to the viewer buffer based on their
criticality.
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VERBOSITY LEVELS
Classification of Memento traces based on the message criticality and on the
requested amount of messages to be displayed. The levels are the following from
the least verbose (most critical) to the most verbose (least critical): Critical, Error,
Warning, Notice, Info, Debug, Verbose

VIEWER BUFFER
Memory area where the Memento application stores the messages to be displayed
in the Memento application.
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